I suggest you ...

Project.json should manage compatibility of packages and do not allow to install incompatible packages.

We can install packages in project.json and some time it allow us to install package in system which are not compatible like the current framework do not allow it or somehow we made it then on the runtime we come to know that there is an issue with functionality.
There should be some checks which allow to install package or dependency which are compatible.

1 vote
Vote
Sign in
Check!
(thinking…)
Reset
or sign in with
  • facebook
  • google
    Password icon
    Signed in as (Sign out)
    You have left! (?) (thinking…)
    Anonymous shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

    0 comments

    Sign in
    Check!
    (thinking…)
    Reset
    or sign in with
    • facebook
    • google
      Password icon
      Signed in as (Sign out)
      Submitting...

      Feedback and Knowledge Base